Issue727

Title use Evaluator instead of Heuristic
Priority meta Status chatting
Superseder Nosy List guillem, jendrik, malte, manuel
Assigned To Keywords
Optional summary
Meta issue for using Evaluator instead of Heuristic in user code.

* Notify Evaluators about state transitions (issue724).

* Move heuristic progress statistics to Evaluator (issue750).

* Allow putting evaluators into documentation sections (issue749).

* Convert Heuristic options to Evaluator (issue766).

* Use Evaluator instead of Heuristic in option parser code (issue718).

* Rename "heuristic" to "evaluator" in variable and function names. Rename 
EvaluationResult::get_h_value to EvaluationResult::get_evaluator_value and do 
similar renamings for EvaluationContext.

* Let ConstEvaluator inherit from Evaluator.

* Clean up obsolete Heuristic forward definitions and heuristic.h includes.

Created on 2017-05-03.11:05:37 by manuel, last changed by jendrik.

Summary
Meta issue for using Evaluator instead of Heuristic in user code.

* Notify Evaluators about state transitions (issue724).

* Move heuristic progress statistics to Evaluator (issue750).

* Allow putting evaluators into documentation sections (issue749).

* Convert Heuristic options to Evaluator (issue766).

* Use Evaluator instead of Heuristic in option parser code (issue718).

* Rename "heuristic" to "evaluator" in variable and function names. Rename 
EvaluationResult::get_h_value to EvaluationResult::get_evaluator_value and do 
similar renamings for EvaluationContext.

* Let ConstEvaluator inherit from Evaluator.

* Clean up obsolete Heuristic forward definitions and heuristic.h includes.
Messages
msg6928 (view) Author: jendrik Date: 2018-03-16.19:25:15
Add item "Clean up obsolete Heuristic forward definitions and heuristic.h includes." to summary.
msg6909 (view) Author: manuel Date: 2018-03-16.15:40:04
Add item.
msg6635 (view) Author: jendrik Date: 2017-11-29.19:12:58
Add item.
msg6634 (view) Author: jendrik Date: 2017-11-29.17:24:34
Update summary.
msg6632 (view) Author: jendrik Date: 2017-11-29.17:13:51
Add item.
msg6630 (view) Author: jendrik Date: 2017-11-29.15:40:59
Update description of agenda item 6.
msg6601 (view) Author: jendrik Date: 2017-11-27.11:16:53
Move TODOs into summary field.
msg6330 (view) Author: manuel Date: 2017-05-03.11:05:37
This issue intends to spread the use of Evaluator in search code and includes
following points.

1. Provide evaluator name for logging.

2. Add option to evaluators for enabling/disabling logging of better h-values.

3. Add option to evaluators for enabling/disabling counting of evaluations.

4. Notify Evaluators about state transitions (issue724).

5. Rename heuristic to evaluator in variable and function names.

With items 2. and 3., we intend to remove dynamic casts for checking if an
Evaluator is a Heuristic. Without the cast to Heuristic, Evaluator must provide
a name for logging (item 1.). Item 4. will finally replace all variables of type
 heuristic with variables of type Evaluator in the search code.
History
Date User Action Args
2018-03-16 19:25:15jendriksetmessages: + msg6928
summary: Meta issue for using Evaluator instead of Heuristic in user code. * Notify Evaluators about state transitions (issue724). * Move heuristic progress statistics to Evaluator (issue750). * Allow putting evaluators into documentation sections (issue749). * Convert Heuristic options to Evaluator (issue766). * Use Evaluator instead of Heuristic in option parser code (issue718). * Rename "heuristic" to "evaluator" in variable and function names. Rename EvaluationResult::get_h_value to EvaluationResult::get_evaluator_value and do similar renamings for EvaluationContext. * Let ConstEvaluator inherit from Evaluator. -> Meta issue for using Evaluator instead of Heuristic in user code. * Notify Evaluators about state transitions (issue724). * Move heuristic progress statistics to Evaluator (issue750). * Allow putting evaluators into documentation sections (issue749). * Convert Heuristic options to Evaluator (issue766). * Use Evaluator instead of Heuristic in option parser code (issue718). * Rename "heuristic" to "evaluator" in variable and function names. Rename EvaluationResult::get_h_value to EvaluationResult::get_evaluator_value and do similar renamings for EvaluationContext. * Let ConstEvaluator inherit from Evaluator. * Clean up obsolete Heuristic forward definitions and heuristic.h includes.
2018-03-16 15:40:04manuelsetmessages: + msg6909
summary: Meta issue for using Evaluator instead of Heuristic in user code. * Notify Evaluators about state transitions (issue724). * Move heuristic progress statistics to Evaluator (issue750). * Allow putting evaluators into documentation sections (issue749). * Use Evaluator instead of Heuristic in option parser code (issue718). * Rename "heuristic" to "evaluator" in variable and function names. Rename EvaluationResult::get_h_value to EvaluationResult::get_evaluator_value and do similar renamings for EvaluationContext. * Let ConstEvaluator inherit from Evaluator. -> Meta issue for using Evaluator instead of Heuristic in user code. * Notify Evaluators about state transitions (issue724). * Move heuristic progress statistics to Evaluator (issue750). * Allow putting evaluators into documentation sections (issue749). * Convert Heuristic options to Evaluator (issue766). * Use Evaluator instead of Heuristic in option parser code (issue718). * Rename "heuristic" to "evaluator" in variable and function names. Rename EvaluationResult::get_h_value to EvaluationResult::get_evaluator_value and do similar renamings for EvaluationContext. * Let ConstEvaluator inherit from Evaluator.
2017-11-30 12:16:07jendriksetsummary: Meta issue for using Evaluator instead of Heuristic in user code. * Notify Evaluators about state transitions (issue724). * Move heuristic progress statistics to Evaluator (issue750). * Allow putting evaluators into documentation sections (issue749). * Use Evaluator instead of Heuristic in option parser code (issue718). * Rename "heuristic" to "evaluator" in variable and function names. * Let ConstEvaluator inherit from Evaluator. -> Meta issue for using Evaluator instead of Heuristic in user code. * Notify Evaluators about state transitions (issue724). * Move heuristic progress statistics to Evaluator (issue750). * Allow putting evaluators into documentation sections (issue749). * Use Evaluator instead of Heuristic in option parser code (issue718). * Rename "heuristic" to "evaluator" in variable and function names. Rename EvaluationResult::get_h_value to EvaluationResult::get_evaluator_value and do similar renamings for EvaluationContext. * Let ConstEvaluator inherit from Evaluator.
2017-11-30 10:44:30guillemsetnosy: + guillem, - gfrances
2017-11-29 19:12:58jendriksetmessages: + msg6635
summary: Meta issue for using Evaluator instead of Heuristic in user code. * Notify Evaluators about state transitions (issue724). * Move heuristic progress statistics to Evaluator (issue750). * Allow putting evaluators into documentation sections (issue749). * Use Evaluator instead of Heuristic in option parser code (issue718). * Rename "heuristic" to "evaluator" in variable and function names. -> Meta issue for using Evaluator instead of Heuristic in user code. * Notify Evaluators about state transitions (issue724). * Move heuristic progress statistics to Evaluator (issue750). * Allow putting evaluators into documentation sections (issue749). * Use Evaluator instead of Heuristic in option parser code (issue718). * Rename "heuristic" to "evaluator" in variable and function names. * Let ConstEvaluator inherit from Evaluator.
2017-11-29 17:24:34jendriksetnosy: + gfrances
messages: + msg6634
summary: This issue intends to spread the use of Evaluator in search code. 1. Provide names for evaluators for logging. 2. Add option to evaluators for enabling/disabling logging of better h-values. 3. Add option to evaluators for enabling/disabling counting of evaluations. 4. Notify Evaluators about state transitions (issue724). 5. Rename "heuristic" to "evaluator" in variable and function names. 6. Use Evaluator instead of Heuristic in option parser code (issue718). 7. Allow putting evaluators into documentation sections (issue749). With items 2. and 3., we intend to remove dynamic casts for checking if an Evaluator is a Heuristic. Without the cast to Heuristic, Evaluator must provide a name for logging (item 1.). Item 4. will finally replace all variables of type heuristic with variables of type Evaluator in the search code. -> Meta issue for using Evaluator instead of Heuristic in user code. * Notify Evaluators about state transitions (issue724). * Move heuristic progress statistics to Evaluator (issue750). * Allow putting evaluators into documentation sections (issue749). * Use Evaluator instead of Heuristic in option parser code (issue718). * Rename "heuristic" to "evaluator" in variable and function names.
2017-11-29 17:13:52jendriksetmessages: + msg6632
summary: This issue intends to spread the use of Evaluator in search code. 1. Provide names for evaluators for logging. 2. Add option to evaluators for enabling/disabling logging of better h-values. 3. Add option to evaluators for enabling/disabling counting of evaluations. 4. Notify Evaluators about state transitions (issue724). 5. Rename "heuristic" to "evaluator" in variable and function names. 6. Use Evaluator instead of Heuristic in option parser code (issue718). With items 2. and 3., we intend to remove dynamic casts for checking if an Evaluator is a Heuristic. Without the cast to Heuristic, Evaluator must provide a name for logging (item 1.). Item 4. will finally replace all variables of type heuristic with variables of type Evaluator in the search code. -> This issue intends to spread the use of Evaluator in search code. 1. Provide names for evaluators for logging. 2. Add option to evaluators for enabling/disabling logging of better h-values. 3. Add option to evaluators for enabling/disabling counting of evaluations. 4. Notify Evaluators about state transitions (issue724). 5. Rename "heuristic" to "evaluator" in variable and function names. 6. Use Evaluator instead of Heuristic in option parser code (issue718). 7. Allow putting evaluators into documentation sections (issue749). With items 2. and 3., we intend to remove dynamic casts for checking if an Evaluator is a Heuristic. Without the cast to Heuristic, Evaluator must provide a name for logging (item 1.). Item 4. will finally replace all variables of type heuristic with variables of type Evaluator in the search code.
2017-11-29 15:40:59jendriksetmessages: + msg6630
summary: This issue intends to spread the use of Evaluator in search code. 1. Provide names for evaluators for logging. 2. Add option to evaluators for enabling/disabling logging of better h-values. 3. Add option to evaluators for enabling/disabling counting of evaluations. 4. Notify Evaluators about state transitions (issue724). 5. Rename "heuristic" to "evaluator" in variable and function names. 6. Merge Heuristic into Evaluator (issue718). With items 2. and 3., we intend to remove dynamic casts for checking if an Evaluator is a Heuristic. Without the cast to Heuristic, Evaluator must provide a name for logging (item 1.). Item 4. will finally replace all variables of type heuristic with variables of type Evaluator in the search code. -> This issue intends to spread the use of Evaluator in search code. 1. Provide names for evaluators for logging. 2. Add option to evaluators for enabling/disabling logging of better h-values. 3. Add option to evaluators for enabling/disabling counting of evaluations. 4. Notify Evaluators about state transitions (issue724). 5. Rename "heuristic" to "evaluator" in variable and function names. 6. Use Evaluator instead of Heuristic in option parser code (issue718). With items 2. and 3., we intend to remove dynamic casts for checking if an Evaluator is a Heuristic. Without the cast to Heuristic, Evaluator must provide a name for logging (item 1.). Item 4. will finally replace all variables of type heuristic with variables of type Evaluator in the search code.
2017-11-27 11:16:53jendriksetstatus: unread -> chatting
title: Use Evaluator instead of Heuristic in more places. -> use Evaluator instead of Heuristic
messages: + msg6601
summary: This issue intends to spread the use of Evaluator in search code. 1. Provide names for evaluators for logging. 2. Add option to evaluators for enabling/disabling logging of better h-values. 3. Add option to evaluators for enabling/disabling counting of evaluations. 4. Notify Evaluators about state transitions (issue724). 5. Rename "heuristic" to "evaluator" in variable and function names. 6. Merge Heuristic into Evaluator (issue718). With items 2. and 3., we intend to remove dynamic casts for checking if an Evaluator is a Heuristic. Without the cast to Heuristic, Evaluator must provide a name for logging (item 1.). Item 4. will finally replace all variables of type heuristic with variables of type Evaluator in the search code.
2017-05-03 11:05:37manuelcreate