Good for a meeting, yes.
First comment for now: I see what you mean. I think it makes little sense to allow assignment for evaluators and landmark factories, but nothing else. So the syntax as it currently stands is not something I'd like to keep indefinitely.
But at a glance I see nothing wrong with something which is like our current syntax but without the words "--evaluator" etc., as in:
h1=ff()
h2=lmcount()
eager_greedy([h1,h2])
or whatever, with support for all plugin types, not just evaluators and landmark factories.
I also don't think it's that much more difficult to write this as
let(h1,ff(),
let(h2,lmcount(),
eager_greedy([h1,h2])
))
but I guess it looks foreign without exposure to functional programming.
|