> My plan would be to remove the optional OptionFlags argument and add optional
> lower_bound = "" and upper_bound = "" arguments.
Too many positional arguments make for hard to read code, especially if they are
all the same type (all strings), since the compiler won't be helpful. It may be
better to wrap the extra information up in a type that communicates the intent
clearly, e.g instead of
add_option(lots, of, options, "10", "100")
something like
add_option(lots, of, options, Bounds("10", "100"))
would be clearer and would cause an error if the positions are counted wrong.
(It's a pity C++ doesn't have something like keyword arguments, but techniques
like this one can be used to simulate them to some extent, especially when
combined with variadic functions.)
|