Operator counting constraints currently get their task in the method
initialize_constraints, which should just create constraints in the LP. We want
to change this by introducing factory classes for constraint generators and
passing them as options to the operator counting heuristic instead of passing
constraint generators. The heuristic then creates operator counting constraints
for its task in its initialization/constructor.
Since "ConstraintGeneratorFactory" sounds like "ConstraintFactoryFactory", I
suggest to also rename the generated object to "OperatorCountingConstraint" or
just "Constraint" (its in the namespace OperatorCounting anyway). The factory
could then be named "ConstraintFactory" or "ConstraintGenerator". What names do
you prefer?
|